*/*: dekeyword ruby on ia64
[gentoo.git] / dev-ruby / net-telnet / net-telnet-0.2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
6
7 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
8 RUBY_FAKEGEM_EXTRADOC="README.md"
9
10 # Don't install the binaries since they don't seem to be intended for
11 # general use and they have very generic names leading to collisions,
12 # e.g. bug 571186
13 RUBY_FAKEGEM_BINWRAP=""
14
15 inherit ruby-fakegem
16
17 DESCRIPTION="Provides telnet client functionality"
18 HOMEPAGE="https://github.com/ruby/net-telnet"
19 SRC_URI="https://github.com/ruby/net-telnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
20
21 LICENSE="|| ( Ruby-BSD BSD-2 )"
22 SLOT="1"
23 KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
24 IUSE="test"
25
26 ruby_add_bdepend "test? ( dev-ruby/minitest )"
27
28 all_ruby_prepare() {
29         sed -i -e '/bundler/ s:^:#:' Rakefile || die
30 }