dev-python/zc-lockfile: keyworded 2.0 for ia64, bug #717946
[gentoo.git] / dev-ruby / backports / backports-3.17.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
7 RUBY_FAKEGEM_TASK_TEST="test"
8
9 RUBY_FAKEGEM_GEMSPEC="backports.gemspec"
10
11 inherit ruby-fakegem
12
13 DESCRIPTION="Backports of Ruby features for older Ruby"
14 HOMEPAGE="https://github.com/marcandre/backports"
15 SRC_URI="https://github.com/marcandre/backports/archive/v${PV}.tar.gz -> $P{P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
20 IUSE=""
21
22 all_ruby_prepare() {
23         # Avoid activesupport test that no longer works in Rails 5. This also avoids
24         # a dependency on activesupport
25         sed -i -e '/test_rails/,/^  end/ s:^:#:' test/_backport_guards_test.rb || die
26
27         sed -i -e '/rubocop/I s:^:#:' Rakefile || die
28 }