dev-python/zc-lockfile: keyworded 2.0 for ia64, bug #717946
[gentoo.git] / dev-ruby / addressable / addressable-2.5.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby23 ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
8 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
9
10 RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
11
12 RUBY_FAKEGEM_EXTRAINSTALL="data"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
17 HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
18
19 LICENSE="Apache-2.0"
20
21 SLOT="0"
22 KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
23 IUSE="doc test"
24
25 ruby_add_rdepend ">=dev-ruby/public_suffix-2.0.2:* <dev-ruby/public_suffix-4:*"
26
27 ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
28
29 all_ruby_prepare() {
30         # Remove spec-related tasks so that we don't need to require rspec
31         # just to build the documentation, bug 383611.
32         sed -i -e '/spectask/d' Rakefile || die
33         rm -f tasks/rspec.rake || die
34         sed -i -e '/bundler/ s:^:#:' \
35                 -e '/^begin/,/^end/ s:^:#:' \
36                 spec/spec_helper.rb || die
37
38         # Remove specs requiring network connectivity
39         rm -f spec/addressable/net_http_compat_spec.rb || die
40
41         # Remove spec that tests against an unreleased github fork
42         rm -f spec/addressable/rack_mount_compat_spec.rb || die
43 }