*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / visualization_msgs / visualization_msgs-1.12.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 CATKIN_HAS_MESSAGES=yes
6 ROS_REPO_URI="https://github.com/ros/common_msgs"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
9 ROS_SUBDIR=${PN}
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="Messages used by higher level packages that deal in visualization-specific data."
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND=""
20 DEPEND="${RDEPEND}"