sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-ros / rosserial_xbee / rosserial_xbee-0.7.6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python2_7 )
8 ROS_SUBDIR=${PN}
9
10 inherit ros-catkin
11
12 DESCRIPTION="Tools to do point to multipoint communication between rosserial nodes connected to an xbee"
13 LICENSE="BSD"
14 SLOT="0"
15 IUSE=""
16
17 RDEPEND="
18         dev-ros/rospy[${PYTHON_USEDEP}]
19         dev-python/pyserial[${PYTHON_USEDEP}]
20         dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
21         dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
22         dev-ros/rosserial_python[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}"