*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / rosnode / rosnode-1.13.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros_comm"
7 KEYWORDS="~amd64 ~arm"
8 ROS_SUBDIR=tools/${PN}
9 PYTHON_COMPAT=( python2_7 )
10
11 inherit ros-catkin
12
13 DESCRIPTION="Command-line tool for displaying debug information about ROS nodes"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-ros/genmsg[${PYTHON_USEDEP}]
20         dev-python/rospkg[${PYTHON_USEDEP}]
21         dev-ros/roslib[${PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}
24         test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"