*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / roslz4 / roslz4-1.13.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros_comm"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python2_7 )
9 ROS_SUBDIR=utilities/${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="Python and C++ implementation of the LZ4 streaming format"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="app-arch/lz4"
19 DEPEND="${RDEPEND}
20         test? ( dev-cpp/gtest )"