*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / roslib / roslib-1.14.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
9 ROS_SUBDIR=core/${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="Base dependencies and support libraries for ROS"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         >=dev-python/rospkg-1.0.37[${PYTHON_USEDEP}]
20         dev-libs/boost:=[threads]
21         dev-ros/rospack
22         dev-ros/ros_environment
23 "
24 DEPEND="${RDEPEND}
25         test? (
26                 dev-cpp/gtest
27                 dev-python/nose[${PYTHON_USEDEP}]
28         )"