dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-ros / roscpp_tutorials / roscpp_tutorials-0.8.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/ros_tutorials"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 CATKIN_HAS_MESSAGES=yes
9 PYTHON_COMPAT=( python2_7 )
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-libs/boost:=[threads]
21         dev-ros/rostime
22         dev-ros/roscpp
23         dev-ros/rosconsole
24         dev-ros/roscpp_serialization
25 "
26 DEPEND="${RDEPEND}"