*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / rosclean / rosclean-1.14.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/ros"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
9 ROS_SUBDIR=tools/${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="Cleanup filesystem resources (e.g. log files)"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
19 DEPEND="${RDEPEND}
20         test? ( dev-python/nose[${PYTHON_USEDEP}] )
21 "