*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / resource_retriever / resource_retriever-1.12.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/resource_retriever"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
8
9 inherit ros-catkin
10
11 DESCRIPTION="Retrieves data from url-format files"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/rosconsole
18         dev-ros/roslib[${PYTHON_USEDEP}]
19         net-misc/curl
20         dev-python/rospkg[${PYTHON_USEDEP}]
21 "
22 DEPEND="${RDEPEND}
23         test? ( dev-cpp/gtest )"