*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / qt_gui / qt_gui-0.3.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
7 KEYWORDS="~amd64"
8 PYTHON_COMPAT=( python2_7 )
9 ROS_SUBDIR=${PN}
10
11 inherit ros-catkin
12
13 DESCRIPTION="ROS infrastructure for an integrated graphical user interface based on Qt"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         dev-qt/qtcore:5
20         dev-python/rospkg[${PYTHON_USEDEP}]
21         >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}"