*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / pr2_msgs / pr2_msgs-1.12.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/pr2/pr2_common"
6 KEYWORDS="~amd64"
7 ROS_SUBDIR=${PN}
8 CATKIN_HAS_MESSAGES=yes
9 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="Messages for representing PR2 state, such as battery information and the PR2 fingertip sensors"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND=""
20 DEPEND="${RDEPEND}"