*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / polled_camera / polled_camera-1.11.13.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-perception/image_common"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 CATKIN_HAS_MESSAGES=yes
9 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/sensor_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="C++ helper classes for implementing a polled camera driver node and requesting images from it"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/roscpp
21         dev-ros/image_transport
22         dev-ros/rosconsole
23 "
24 DEPEND="${RDEPEND}"