*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / pluginlib / pluginlib-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/pluginlib"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python2_7 )
9 ROS_SUBDIR="${PN}"
10
11 inherit ros-catkin
12
13 DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
14 LICENSE="BSD"
15 SLOT="0"
16 IUSE=""
17
18 RDEPEND="
19         >=dev-ros/class_loader-0.3.5:=
20         dev-ros/rosconsole
21         dev-ros/roslib[${PYTHON_USEDEP}]
22         dev-libs/boost:=
23         dev-libs/tinyxml2:=
24 "
25 DEPEND="${RDEPEND}
26         test? ( dev-cpp/gtest )"
27 PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )