*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / moveit_msgs / moveit_msgs-0.9.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros-planning/moveit_msgs"
7 CATKIN_HAS_MESSAGES=yes
8 KEYWORDS="~amd64 ~arm"
9 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="
11         dev-ros/actionlib_msgs
12         dev-ros/sensor_msgs
13         dev-ros/geometry_msgs
14         dev-ros/trajectory_msgs
15         dev-ros/shape_msgs
16         dev-ros/std_msgs
17         dev-ros/octomap_msgs
18         dev-ros/object_recognition_msgs
19 "
20
21 inherit ros-catkin
22
23 DESCRIPTION="Messages, services and actions used by MoveIt"
24 LICENSE="BSD"
25 SLOT="0"
26 IUSE=""
27
28 RDEPEND=""
29 DEPEND="${RDEPEND}"