*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / hector_nav_msgs / hector_nav_msgs-0.3.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 CATKIN_HAS_MESSAGES=yes
9 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/geometry_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="Messages and services used in the hector_slam stack"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND=""
20 DEPEND="${RDEPEND}"