*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / hector_mapping / hector_mapping-0.3.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8 CATKIN_HAS_MESSAGES=yes
9 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
10 CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
11
12 inherit ros-catkin
13
14 DESCRIPTION="SLAM approach that can be used without odometry and on platforms that exhibit roll/pitch motion"
15 LICENSE="BSD"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="
20         dev-ros/roscpp
21         dev-ros/tf
22         dev-ros/message_filters
23         dev-ros/laser_geometry
24         dev-ros/tf_conversions
25         dev-libs/boost:=[threads]
26 "
27 DEPEND="${RDEPEND}
28         dev-cpp/eigen:3"
29 PATCHES=( "${FILESDIR}/boost170.patch" )