*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / genpy / genpy-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 ROS_REPO_URI="https://github.com/ros/genpy"
7 KEYWORDS="~amd64 ~arm"
8 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
9
10 inherit ros-catkin
11
12 DESCRIPTION="Python ROS message and service generators"
13 HOMEPAGE="http://wiki.ros.org/genpy"
14 LICENSE="BSD"
15 SLOT="0/${PV}"
16 IUSE=""
17
18 RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]
19                 dev-python/pyyaml[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}
21         test? (
22                 dev-python/nose[${PYTHON_USEDEP}]
23         )
24 "