*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-ros / genmsg / genmsg-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros/genmsg"
6 KEYWORDS="~amd64 ~arm"
7 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
8
9 inherit ros-catkin
10
11 DESCRIPTION="Python library for generating ROS message and service data structures for various languages"
12 LICENSE="BSD"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND=""
17 DEPEND="${RDEPEND}
18         test? ( dev-python/nose[${PYTHON_USEDEP}] )
19 "