dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-qt / qtx11extras / qtx11extras-5.14.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit qt5-build
7
8 DESCRIPTION="Linux/X11-specific support library for the Qt5 framework"
9
10 if [[ ${QT5_BUILD_TYPE} == release ]]; then
11         KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
12 fi
13
14 IUSE=""
15
16 RDEPEND="
17         ~dev-qt/qtcore-${PV}
18         ~dev-qt/qtgui-${PV}[X]
19 "
20 DEPEND="${RDEPEND}
21         test? ( ~dev-qt/qtwidgets-${PV} )
22 "