45e44f6d5f0cadfa9cf8cb5b2894fcb8c819d829
[gentoo.git] / dev-qt / qtwidgets / qtwidgets-5.14.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 QT5_MODULE="qtbase"
7 inherit qt5-build
8
9 DESCRIPTION="Set of components for creating classic desktop-style UIs for the Qt5 framework"
10
11 if [[ ${QT5_BUILD_TYPE} == release ]]; then
12         KEYWORDS="amd64 arm arm64 ~hppa ~ppc ppc64 ~sparc x86"
13 fi
14
15 # keep IUSE defaults in sync with qtgui
16 IUSE="gles2-only gtk +png +X"
17
18 DEPEND="
19         ~dev-qt/qtcore-${PV}:5=
20         ~dev-qt/qtgui-${PV}[gles2-only=,png=,X?]
21         gtk? (
22                 ~dev-qt/qtgui-${PV}[dbus]
23                 x11-libs/gtk+:3
24                 x11-libs/libX11
25                 x11-libs/pango
26         )
27 "
28 RDEPEND="${DEPEND}"
29
30 QT5_TARGET_SUBDIRS=(
31         src/tools/uic
32         src/widgets
33         src/plugins/platformthemes
34 )
35
36 QT5_GENTOO_CONFIG=(
37         gtk:gtk3:
38         ::widgets
39         !:no-widgets:
40 )
41
42 QT5_GENTOO_PRIVATE_CONFIG=(
43         :widgets
44 )
45
46 src_configure() {
47         local myconf=(
48                 -opengl $(usex gles2-only es2 desktop)
49                 $(qt_use gtk)
50                 -gui
51                 $(qt_use png libpng system)
52                 -widgets
53                 $(qt_use X xcb system)
54                 $(usex X '-xcb-xlib -xcb-xinput -xkb -xkbcommon' '')
55         )
56         qt5-build_src_configure
57 }