dev-qt/qtwayland: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-qt / qtwayland / qtwayland-5.14.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit qt5-build
6
7 DESCRIPTION="Wayland platform plugin for Qt"
8
9 if [[ ${QT5_BUILD_TYPE} == release ]]; then
10         KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
11 fi
12
13 IUSE="vulkan X"
14
15 DEPEND="
16         >=dev-libs/wayland-1.6.0
17         ~dev-qt/qtcore-${PV}
18         ~dev-qt/qtdeclarative-${PV}
19         ~dev-qt/qtgui-${PV}[egl,libinput,vulkan=]
20         media-libs/mesa[egl]
21         >=x11-libs/libxkbcommon-0.2.0
22         vulkan? ( dev-util/vulkan-headers )
23         X? (
24                 ~dev-qt/qtgui-${PV}[-gles2-only]
25                 x11-libs/libX11
26                 x11-libs/libXcomposite
27         )
28 "
29 RDEPEND="${DEPEND}"
30
31 src_prepare() {
32         use X || rm -r config.tests/xcomposite || die
33
34         qt5-build_src_prepare
35 }
36
37 src_configure() {
38         local myqmakeargs=(
39                 --
40                 $(qt_use vulkan feature-wayland-vulkan-server-buffer)
41                 $(qt_use X feature-xcomposite-egl)
42                 $(qt_use X feature-xcomposite-glx)
43         )
44         qt5-build_src_configure
45 }