dev-qt/qtscript: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-qt / qtscript / qtscript-5.14.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit qt5-build
6
7 DESCRIPTION="Application scripting library for the Qt5 framework (deprecated)"
8
9 if [[ ${QT5_BUILD_TYPE} == release ]]; then
10         KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86"
11 fi
12
13 IUSE="+jit scripttools"
14
15 DEPEND="
16         ~dev-qt/qtcore-${PV}
17         scripttools? (
18                 ~dev-qt/qtgui-${PV}
19                 ~dev-qt/qtwidgets-${PV}
20         )
21 "
22 RDEPEND="${DEPEND}"
23
24 src_prepare() {
25         qt_use_disable_mod scripttools widgets \
26                 src/src.pro
27
28         qt5-build_src_prepare
29 }
30
31 src_configure() {
32         local myqmakeargs=(
33                 JAVASCRIPTCORE_JIT=$(usex jit 'yes' 'no')
34         )
35         qt5-build_src_configure
36 }