dev-qt/qtprintsupport: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-qt / qtprintsupport / qtprintsupport-5.14.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 QT5_MODULE="qtbase"
6 VIRTUALX_REQUIRED="test"
7 inherit qt5-build
8
9 DESCRIPTION="Printing support library for the Qt5 framework"
10
11 if [[ ${QT5_BUILD_TYPE} == release ]]; then
12         KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
13 fi
14
15 IUSE="cups gles2-only"
16
17 RDEPEND="
18         ~dev-qt/qtcore-${PV}:5=
19         ~dev-qt/qtgui-${PV}[gles2-only=]
20         ~dev-qt/qtwidgets-${PV}[gles2-only=]
21         cups? ( >=net-print/cups-1.4 )
22 "
23 DEPEND="${RDEPEND}
24         test? ( ~dev-qt/qtnetwork-${PV} )
25 "
26
27 QT5_TARGET_SUBDIRS=(
28         src/printsupport
29         src/plugins/printsupport
30 )
31
32 QT5_GENTOO_CONFIG=(
33         cups
34 )
35
36 src_configure() {
37         local myconf=(
38                 $(qt_use cups)
39                 -opengl $(usex gles2-only es2 desktop)
40         )
41         qt5-build_src_configure
42 }