dev-qt/qthelp: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-qt / qthelp / qthelp-5.14.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 QT5_MODULE="qttools"
6 inherit qt5-build
7
8 DESCRIPTION="Qt5 module for integrating online documentation into applications"
9
10 if [[ ${QT5_BUILD_TYPE} == release ]]; then
11         KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
12 fi
13
14 IUSE=""
15
16 DEPEND="
17         ~dev-qt/qtcore-${PV}:5=
18         ~dev-qt/qtgui-${PV}
19         ~dev-qt/qtnetwork-${PV}
20         ~dev-qt/qtsql-${PV}[sqlite]
21         ~dev-qt/qtwidgets-${PV}
22 "
23 RDEPEND="${DEPEND}"
24
25 QT5_TARGET_SUBDIRS=(
26         src/assistant/help
27         src/assistant/qcollectiongenerator
28         src/assistant/qhelpgenerator
29 )