4ef54c83f3633bd353f40f448f9a64e8a1202f7e
[gentoo.git] / dev-qt / qtdbus / qtdbus-5.14.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 QT5_MODULE="qtbase"
6 inherit qt5-build
7
8 DESCRIPTION="Qt5 module for inter-process communication over the D-Bus protocol"
9
10 if [[ ${QT5_BUILD_TYPE} == release ]]; then
11         KEYWORDS="amd64 arm arm64 ~hppa ~ppc ppc64 ~sparc x86"
12 fi
13
14 IUSE=""
15
16 DEPEND="
17         ~dev-qt/qtcore-${PV}:5=
18         >=sys-apps/dbus-1.4.20
19 "
20 RDEPEND="${DEPEND}"
21
22 QT5_TARGET_SUBDIRS=(
23         src/dbus
24         src/tools/qdbusxml2cpp
25         src/tools/qdbuscpp2xml
26 )
27
28 QT5_GENTOO_CONFIG=(
29         :dbus
30         :dbus-linked:
31 )
32
33 QT5_GENTOO_PRIVATE_CONFIG=(
34         :dbus
35         :dbus-linked
36 )
37
38 src_configure() {
39         local myconf=(
40                 -dbus-linked
41         )
42         qt5-build_src_configure
43 }