*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / zstandard / zstandard-0.8.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Zstandard Bindings for Python"
11 HOMEPAGE="https://pypi.org/project/zstandard/ https://github.com/indygreg/python-zstandard"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="BSD"
16 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17
18 RDEPEND="dev-python/cffi:=[${PYTHON_USEDEP}]"
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
20         ${RDEPEND}"