*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / zope-i18nmessageid / zope-i18nmessageid-5.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
6
7 inherit distutils-r1
8
9 MY_PN=${PN/-/.}
10 MY_P=${MY_PN}-${PV}
11
12 DESCRIPTION="Zope i18nmessageid Architecture"
13 HOMEPAGE="https://github.com/zopefoundation/zope.i18nmessageid http://docs.zope.org/zope.i18nmessageid/"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
15
16 LICENSE="ZPL"
17 SLOT="0"
18 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
19
20 RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
21 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
22
23 S="${WORKDIR}/${MY_P}"
24
25 distutils_enable_tests setup.py
26
27 python_install_all() {
28         distutils-r1_python_install_all
29
30         # remove .pth files since dev-python/namespace-zope handles the ns
31         find "${D}" -name '*.pth' -delete || die
32 }