dev-python/zc-lockfile: keyworded 2.0 for ia64, bug #717946
[gentoo.git] / dev-python / zc-lockfile / zc-lockfile-2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
6
7 inherit distutils-r1
8
9 MY_PN="${PN/-/.}"
10 MY_P=${MY_PN}-${PV}
11
12 DESCRIPTION="Basic inter-process locks"
13 HOMEPAGE="https://pypi.org/project/zc.lockfile/"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
15
16 LICENSE="ZPL"
17 SLOT="0"
18 KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
19 IUSE="test"
20
21 RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
22 DEPEND="${RDEPEND}
23         test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
24
25 S="${WORKDIR}"/${MY_P}
26
27 DOCS=( CHANGES.rst README.rst )
28
29 distutils_enable_tests nose
30
31 # Prevent incorrect installation of data file
32 python_prepare_all() {
33         sed -e '/^    include_package_data/d' -i setup.py || die
34         distutils-r1_python_prepare_all
35 }
36
37 python_install() {
38         distutils-r1_python_install
39
40         python_moduleinto zc
41         python_domodule src/zc/__init__.py
42 }
43
44 python_install_all() {
45         distutils-r1_python_install_all
46
47         find "${D}" -name '*.pth' -delete || die
48 }