*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / zake / zake-0.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Set of testing utilities for the kazoo library"
10 HOMEPAGE=" https://github.com/yahoo/Zake"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         dev-python/nose[${PYTHON_USEDEP}]
22         dev-python/testtools[${PYTHON_USEDEP}]
23         dev-python/flake8[${PYTHON_USEDEP}]"
24 RDEPEND="
25         dev-python/kazoo[${PYTHON_USEDEP}]
26         dev-python/six[${PYTHON_USEDEP}]"
27
28 python_test() {
29         ${EPYTHON} -m nose || die
30 }