*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / yolk / yolk-0.4.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Tool and library for querying PyPI and locally installed Python packages"
11 HOMEPAGE="https://pypi.org/project/yolk/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="examples"
18
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         dev-python/yolk-portage[${PYTHON_USEDEP}]"
22 RDEPEND="${DEPEND}"
23
24 python_install_all() {
25         distutils-r1_python_install_all
26
27         if use examples; then
28                 docinto examples/plugins
29                 dodoc -r examples/plugins/.
30         fi
31 }