*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / yarl / yarl-1.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_{6,7,8} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Yet another URL library"
10 HOMEPAGE="https://github.com/aio-libs/yarl/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm arm64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="
20         >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
21         >=dev-python/idna-2.0[${PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
26
27 python_prepare_all() {
28         # don't use pytest-runner for tests
29         sed -i 's|"pytest-runner"||' setup.py || die
30
31         distutils-r1_python_prepare_all
32 }
33
34 python_test() {
35         py.test -v tests || die "Tests fail with ${EPYTHON}"
36 }