*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / xmltodict / xmltodict-0.11.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{2_7,3_6,3_7} pypy3 )
6 inherit distutils-r1
7
8 DESCRIPTION="Makes working with XML feel like you are working with JSON"
9 HOMEPAGE="https://github.com/martinblech/xmltodict/ https://pypi.org/project/xmltodict/"
10 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~arm64 x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
19         test? ( dev-python/nose[${PYTHON_USEDEP}] )"
20
21 python_test() {
22         nosetests || die "Tests fail with ${EPYTHON}"
23 }