*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / xmlschema / xmlschema-1.0.16.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
7 inherit distutils-r1
8
9 DESCRIPTION="An XML Schema validator and decoder"
10 HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
11 SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="
20         dev-python/elementpath[${PYTHON_USEDEP}]"
21 BDEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 dev-python/lxml[${PYTHON_USEDEP}]
25                 $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' -2)
26         )"
27
28 python_test() {
29         "${EPYTHON}" xmlschema/tests/test_all.py -v ||
30                 die "Tests fail with ${EPYTHON}"
31 }