*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / xlsxwriter / xlsxwriter-0.7.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
7
8 inherit distutils-r1
9
10 MY_PN="XlsxWriter"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="Python module for creating Excel XLSX files"
14 HOMEPAGE="https://pypi.org/project/XlsxWriter/ https://github.com/jmcnamara/XlsxWriter"
15 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
16
17 SLOT="0"
18 LICENSE="BSD"
19 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
20 IUSE="test"
21
22 RDEPEND=""
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]
25         test? ( dev-python/nose[${PYTHON_USEDEP}] )
26 "
27
28 S="${WORKDIR}"/${MY_P}
29
30 # Missing from tarball
31 # https://github.com/jmcnamara/XlsxWriter/issues/327
32 RESTRICT=test
33
34 python_test() {
35         nosetests --verbosity=3 || die
36 }