*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / wsproto / wsproto-0.11.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="WebSockets state-machine based protocol implementation"
11 HOMEPAGE="https://github.com/python-hyper/wsproto https://pypi.python.org/pypi/wsproto"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         =dev-python/h11-0.7*[${PYTHON_USEDEP}]
22         virtual/python-enum34[${PYTHON_USEDEP}]
23 "
24 DEPEND="
25         ${RDEPEND}
26         test? (
27                 dev-python/pytest[${PYTHON_USEDEP}]
28         )
29 "
30
31 python_test() {
32         py.test -v || die "Testing failed"
33 }