*/*: downgrade m68k down to ~m68k
[gentoo.git] / dev-python / wheel / wheel-0.34.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
8
9 inherit distutils-r1 eutils
10
11 DESCRIPTION="A built-package format for Python"
12 HOMEPAGE="https://pypi.org/project/wheel/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14 SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
19
20 distutils_enable_tests pytest
21
22 src_prepare() {
23         sed \
24                 -e 's:--cov=wheel::g' \
25                 -i setup.cfg || die
26         distutils-r1_src_prepare
27 }