*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / werkzeug / werkzeug-0.15.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 MY_PN="Werkzeug"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="Collection of various utilities for WSGI applications"
14 HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.org/project/Werkzeug/ https://github.com/pallets/werkzeug"
15 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
16
17 LICENSE="BSD"
18 SLOT="0"
19 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
20 IUSE="test"
21 RESTRICT="!test? ( test )"
22
23 RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
24 DEPEND="${RDEPEND}
25         dev-python/setuptools[${PYTHON_USEDEP}]
26         test? (
27                 dev-python/requests[${PYTHON_USEDEP}]
28                 dev-python/pytest[${PYTHON_USEDEP}]
29                 dev-python/pytest-xprocess[${PYTHON_USEDEP}]
30         )"
31
32 S="${WORKDIR}/${MY_P}"
33
34 python_compile() {
35         distutils-r1_python_compile
36 }
37
38 python_test() {
39         pytest -vv tests || die "Tests failed under ${EPYTHON}"
40 }