*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / webob / webob-1.8.5-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
7
8 inherit distutils-r1
9
10 MY_PN=WebOb
11 MY_P=${MY_PN}-${PV}
12
13 DESCRIPTION="WSGI request and response object"
14 HOMEPAGE="https://webob.org/"
15 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
20
21 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
22
23 S="${WORKDIR}/${MY_P}"
24
25 distutils_enable_sphinx docs 'dev-python/alabaster'
26 distutils_enable_tests pytest
27
28 python_prepare_all() {
29         sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
30         distutils-r1_python_prepare_all
31 }