*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / webcolors / webcolors-1.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Color names and value formats defined by the HTML and CSS specifications"
11 HOMEPAGE="https://pypi.org/project/webcolors/ https://github.com/ubernostrum/webcolors"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="BSD"
16 KEYWORDS="alpha amd64 ~arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="
21         test? ( dev-python/nose[${PYTHON_USEDEP}] )
22         "
23
24 python_test() {
25         nosetests --verbose || die
26 }