*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / vine / vine-1.1.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Python Promises"
10 HOMEPAGE="https://pypi.org/project/vine/ https://github.com/celery/vine"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 x86"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND=""
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         test? (
22                 >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
23                 >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
24         )"
25
26 python_test() {
27         esetup.py test
28 }