*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / venusian / venusian-1.0_p20161030.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_6 )
6
7 COMMIT="ec4032596e3aec987ba29b62cac701608ef3b523"
8
9 inherit distutils-r1
10
11 DESCRIPTION="A library for deferring decorator actions"
12 HOMEPAGE="http://www.pylonsproject.org/"
13 #SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14 SRC_URI="https://github.com/Pylons/venusian/archive/${COMMIT}.zip -> ${P}.zip"
15
16 LICENSE="repoze"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 RDEPEND="
23         "
24 DEPEND="${RDEPEND}
25         dev-python/setuptools[${PYTHON_USEDEP}]
26         test? ( dev-python/nose[${PYTHON_USEDEP}]
27                 >=dev-python/nose-exclude-0.1.9[${PYTHON_USEDEP}] )
28         "
29
30 S="${WORKDIR}/${PN}-${COMMIT}"
31
32 python_test() {
33         # copy the zipfile to the fixtures dir, setup.py doesn't
34         cp "${S}"/venusian/tests/fixtures/zipped.zip "${BUILD_DIR}"/lib/venusian/tests/fixtures/ || die "Failed to cp zipfile.zip"
35
36         cd "${BUILD_DIR}/lib/venusian"
37         nosetests --exclude-dir=tests/fixtures || die "Tests fail with ${EPYTHON}"
38 }