*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / vatnumber / vatnumber-1.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Module to validate VAT numbers"
10 HOMEPAGE="https://pypi.org/project/vatnumber/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test vies"
17 RESTRICT="!test? ( test )"
18
19 RDEPEND="vies? ( dev-python/suds[${PYTHON_USEDEP}] )"
20 DEPEND="${RDEPEND}
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         test? ( dev-python/suds[${PYTHON_USEDEP}] )"
23
24 PATCHES=( "${FILESDIR}"/${P}-skiptest.patch )
25
26 python_test() {
27         esetup.py test
28 }
29
30 src_install() {
31         distutils-r1_src_install
32         dodoc COPYRIGHT README CHANGELOG
33 }