*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / utmp / utmp-0.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="utmp/wtmp reader"
11 HOMEPAGE="https://pypi.org/project/utmp/ https://srcco.de/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="Apache-2.0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE=""
18
19 RDEPEND="
20         dev-python/six[${PYTHON_USEDEP}]
21         !sys-apps/utempter"
22 DEPEND="${RDEPEND}
23         dev-python/setuptools[${PYTHON_USEDEP}]"
24
25 python_prepare_all() {
26         sed "s:'flake8'::g" -i setup.py || die
27         distutils-r1_python_prepare_all
28 }