*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / unidecode / unidecode-1.1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
7 PYTHON_REQ_USE="wide-unicode(+)"
8
9 MY_PN=Unidecode
10 MY_P=${MY_PN}-${PV}
11
12 inherit distutils-r1
13
14 DESCRIPTION="Module providing ASCII transliterations of Unicode text"
15 HOMEPAGE="https://pypi.org/project/Unidecode/"
16 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
17
18 LICENSE="GPL-2+"
19 SLOT="0"
20 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
21
22 S=${WORKDIR}/${MY_P}
23
24 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
25 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
26
27 python_test() {
28         esetup.py test
29 }