*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / u-msgpack / u-msgpack-2.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
6
7 inherit distutils-r1
8
9 MY_PN="${PN}-python"
10 MY_P="${MY_PN}-${PV}"
11
12 DESCRIPTION="A portable, lightweight MessagePack serializer and deserializer"
13 HOMEPAGE="https://github.com/vsergeev/u-msgpack-python https://pypi.org/project/u-msgpack-python/"
14 SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
19 IUSE="test"
20
21 RDEPEND=""
22 DEPEND="${RDEPEND}
23         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
24
25 RESTRICT="!test? ( test )"
26
27 S=${WORKDIR}/${MY_P}
28
29 PATCHES=("${FILESDIR}"/${P}-little-endian.patch)
30
31 python_test() {
32         py.test -v || die "Tests fail with ${EPYTHON}"
33 }