*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / twython / twython-3.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="An easy (and up to date) way to access Twitter data with Python"
11 HOMEPAGE="https://github.com/ryanmcgrath/twython"
12 SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="MIT"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18
19 DEPEND=""
20 RDEPEND=">=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
21         >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"