*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-python / turbokid / turbokid-1.0.5-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 MY_PN="TurboKid"
10 MY_P="${MY_PN}-${PV}"
11
12 DESCRIPTION="Python template plugin that supports Kid templates"
13 HOMEPAGE="https://pypi.org/project/TurboKid/"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 S="${WORKDIR}/${MY_P}"
23
24 RDEPEND=">=dev-python/kid-0.9.6[${PYTHON_USEDEP}]"
25 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
26         test? ( ${RDEPEND}
27                 dev-python/nose[${PYTHON_USEDEP}] )"
28
29 python_test() {
30         esetup.py test
31 }