*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-python / translationstring / translationstring-1.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Utility library for i18n relied on by various Repoze packages"
11 HOMEPAGE="https://github.com/Pylons/translationstring https://pypi.org/project/translationstring/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="repoze"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 RDEPEND=""
21
22 # Include COPYRIGHT.txt because the license seems to require it.
23 DOCS=( COPYRIGHT.txt README.rst )
24
25 python_test() {
26         esetup.py test
27 }
28
29 src_install() {
30         distutils-r1_src_install
31
32         # Install only the .rst source, as sphinx processing requires a
33         # theme only available from git that contains hardcoded references
34         # to files on https://static.pylonsproject.org/ (so the docs would
35         # not actually work offline). Install into a "docs" subdirectory
36         # so the reference in the README remains correct.
37         docinto docs
38         docompress -x usr/share/doc/${PF}/docs
39         dodoc docs/*.rst
40 }